Problém s motoráky 830

Vojta365

Začátečník
#1
Mám takový menší problém. V Open Rails si jezdím už delší dobu a mám celkem rozsáhlý vozový park. Vše mi jezdí krásně a bez potíží. Vše kromě motoráků 830 a 831.
Vždy, když se chci v jednom z nich projet nebo i když je pouze v soupravě a já řídím jiný stroj, a začnu přidávat výkon, souprava se okamžitě po uvedení do pohybu zastaví, začne se kymácet a na rychloměru se ukáže NaN. Mohl by mi prosím někdo poradit nebo poslat .eng jeho 830?
 

Vojta365

Začátečník
#4
První den na fóru a hned se ztrapním. Už několik měsíců si s tím problémem lámu hlavu a dnes ráno, chvíli po tom co sem napíšu si uvědomím, že jsem pravděpodobně vůbec nestáhl chování modelu. A opravdu. Všechny 830 (kromě jedné od Jaceka, ale s tou si už poradím) fungují. Tímto bych se rád omluvil za zbytečné zahlcení fóra odpadem a děkuji mnohokrát za pomoc.
 

Josef Vogeltanz

Provozní technik
#5
Nj. OR je v tomhle docela blbuvzdornej. Samotného modelu si totiž nijak nevšimne. Zajímá jej až ve chvíli, kdy se o něm dočte v engu přes parametr WagonShape (souhlasí-li název souboru modelu s tím. co je ve stejném adresáři). A pokud není vedoucím vozidlem, prostě jej vynechá. Tohle MSTS nedovolil a kromě ježdění ses musel starat nejen o funkční trainset, ale i o funkční consisty.
A .eng (příp. .wag) je jen jiné pojmenování pro tzv. chování modelu.
 
#6
Jestliže "nebylo staženo chování", pak to znamená, že chybí soubor *.eng a potom, pokud se souprava skládá pomocí různých programů pro tvorbu "consistů" (od kterých já osobně dávám ruce pryč), vůbec nemůže jít stroj/vůz do soupravy vložit, poněvadž program jej v trainsetu "neuvidí". Je-li souprava poskládána "ručně" v texťáku a ORTS nenajde v trainsetu *.eng, nebo *.wag (v případě vozu), ohledně rozměrů modelu sáhne po souboru "default.wag" a na oné pozici v soupravě bude prázdné místo (jako by dva vozy byly spojené neviditelnou tyčí), přičemž souprava normálně pojede. Nesetkal jsem se zatím s popsaným chováním, ale pochopitelně nemůžeme vyloučit, zda se v posledních verzích ORTS (zdroják se stále vyvíjí) něco nezměnilo.
ORTS je dokonce natolik blbuvzdorné, že pokud u AI ("traffic", tj. počítačem řízené soupravy) soupravy nenajde *.eng stroje v čele soupravy (na který se odkazuje v souboru *.con), tak souprava stejně jede - ORTS navíc u AI souprav nepoužívá detailní fyziku strojů a vozů, ale nějakou zjednodušenou (hlavně u 843 je znát, jak při dojíždění k místu zastavení několikrát "zavrká" plynem).
 

Vojta365

Začátečník
#7
Nevím no, stáhl jsem chování znovu a šlo to. Asi jsem napsal předtím blbost, každopádně to nyní funguje. Díky za vysvětlení.
 
Nahoře